Coffee Forum

Please login or register.

BeanGreen

Author Topic: Em6900 Steam Problems  (Read 4475 times)

buchanan

  • Instant Drinker
  • *
  • Posts: 1
  • I Love YaBB 2!
Em6900 Steam Problems
« on: 15/03/2010, 11:50 AM »
Just a question for anyone out there with a 'sunbeam EM6900' coffee machine. The steam wand just isn't up to scratch, it seems to be pumping out more water then steam. I have replaced the tip of the steam wand with a smaller hole with no success. My coffee machine has run out of warranty, and im not to sure what to do with it. does anyone out there know how to fix this problem.  :'(  


cheers B



cafeservices.com.au

  • Instant Drinker
  • *
  • Posts: 1
  • Gender: Male
Em6900 Steam Problems
« Reply #1 on: 15/03/2010, 10:22 PM »
Where are you based??
Independent advice and service for the Cafe Industry.

Honest_Gaza

  • Barista
  • ***
  • Posts: 147
  • Gender: Male
  • No more Instant Cofee thanks
Em6900 Steam Problems
« Reply #2 on: 17/03/2010, 08:37 AM »
Just guessing here....but have you performed regular "descaling" of the machine ?
Sunbeam EM7000 (replaced EM6910 after 5 Years use...but is now the 3rd EM7000 Machine)
Sunbeam EM6910 (replaced faulty EM6900)
Sunbeam EM0480 Grinder (replaced a Solis 167 that nearly had me arrested for murder)

BeanGreen

 

Related Topics

  Subject / Started by Replies Last post
5 Replies
6128 Views
Last post 11/01/2009, 11:22 AM
by avitephen
10 Replies
5726 Views
Last post 09/10/2014, 08:35 AM
by kiwinick
7 Replies
3822 Views
Last post 30/04/2014, 08:43 PM
by askthe coffeeguy
8 Replies
3905 Views
Last post 09/01/2015, 08:51 PM
by mulquemi
5 Replies
2692 Views
Last post 15/01/2015, 09:48 PM
by Moon